NPM update actions

Published by Violacase on

Remember:

When scaffolding a new yeoman project after initial download you must install  the needed dependencies with:

npm install
bower install
gulp install
(grunt install?)

Updating npm dependencies

Install update tool (if not already done)

 npm install -g npm-check-updates

Check outdated packages

ncu

Update packages in package.json

 ncu -u

Update local packages regarding package.json

 npm update

Updating bower libraries

Install update tool (if not already done)

 npm install -g npm-check-updates

Check outdated packages

 ncu -m bower

Update packages in bower.json

 ncu -u -m bower

Update local packages regarding package.json

 bower update

Update bower.json forcing using the upgrades

 bower update -a/--upgradeAll

Locking package versions

Lock down version using npm-shrinkwrap.json

 npm shrinkwrap --dev
Categories: Algemeen